
ECE 3254 Laboratory Name ________________________
Psipce simulation – simple resistor circuit Date: ________________
Laboratory #1  Fall 2009 Bench: __________
PRELAB (100 points total)

Prelab assignment (to be completed before coming to Lab 1):

1. Read through the entire Lab1 handout and Lab1 notes. 
Obtain Pspice Student 9.1 from the “Pspice 9.1 Student Ver” link on the ECE 3254 Lab web site. 
Install Pspice on a portable computer. Bring this computer to class. (10 points)
To complete the Lab more quickly, you may wish to begin the procedure in Part I and Part III of the 
handout. 

2. What is the equation for Ohms law in terms of voltage (V), current (I), and resistance (R)?  (10 points)

3. Draw a circuit showing a voltage source, a resistor, and a voltmeter that measures the voltage across 
the resistor (hint: draw fig 1-1 with a Voltmeter added).  (15 points)

4.  Draw a circuit showing a voltage source, a resistor, and an ammeter to measure the current through the 
resistor (hint: draw fig 1-1 with an Ammeter added). (15 points)

5. For the circuit in Fig 1-1, calculate the voltage across R1 and the current through R1, with Vs = 9VDC 
and R1 = 1kΩ. Show equation(s) and values used in calculation(s). Copy your expected voltage and 
current to Part I-19, Part II-3 and Part II-4 of the Lab data sheet.  (20 points)

6. For the circuit in Fig 1-2 with Vs = 9.0V and R1 = 1kΩ, and R2 = 560Ω, calculate the currents and 
voltages that you would expect to measure across and through the resistors. Show equation(s) and 
values used in calculation(s). Copy your expected voltages and current to Part III-9 and Part IV-2 of 
the Lab data sheet.  (30 points)
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ECE 3254   
Simple Resistor Circuit Simulation and Measurement
Laboratory #1
Last Revised: 09-01-2009 

Bring your portable computer with Pspice student 9.1 installed.

NOTE: You will want to save your work frequently as you go so that if something happens to Pspice, 
you do not have to repeat all of your work. You can do this by clicking File → Save, or by clicking 
the save button .

Record all measurements and calculations on the data sheet. 
Always include the units for each measurement and calculation!
A manual for each piece of equipment is available if you need it.  If you are unsure of how to make a 
measurement, it is your responsibility to ask for help or to consult the manual.  

We will use the Agilent 34401A and Fluke Model 45 Digital Multimeter (DMM) to measure resistance, 
DC volts, and DC current. Measure the resistance of the resistor using the Agilent 34401A multimeter set 
on 2-wire ohms.  NOTE: Individual resistors must always be removed/separated from a circuit when the 
resistor's resistance is measured.

Part I: Pspice Simulation of a Resistor and a DC Voltage Source

Enter the circuit of Fig 1-1 into the Pspice Schematic, with Vs = 9VDC and R1 = 1kΩ.

 
   Figure 1-1

Draw the circuit in Pspice Schematic

1. Start Pspice by clicking Start → Programs → Pspice Student → Schematics
When Pspice has started, you should have a window like this

2. Click “File” → “New”, then “File” → “Save As” → Lab1-I, 
Save the file in a convenient location where you can easily find it

3. At the top of the window, click (see images below) “Draw” → “Get New Part” → scroll down to 
“r” → click “Place” → move the cursor to the schematic area and right click the mouse to place the 
resistor in the schematic. See the image with instruction 6 for a suggestion about how to arrange 
your parts. [Note: After a part has been placed, you may continue to place more of the same type 
part, select another part, or hit the esc key to end part insertion.]  

4.  Now scroll down to “VDC” → click “Place” → move the cursor to the schematic area and right 
click mouse to place the voltage source in the schematic.
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5. Now scroll to “GND_Earth” → click “Place” → move the cursor to the schematic area and right 
click mouse to place the ground in the schematic. Click the Esc key after you have placed the 
ground.

6. Click “Close” on the Part Browser Basic box. You should now have something that looks like this 
in your schematic area.

7. Right click the resistor to get the move position indication on the cursor (four way arrow) and the 
resistor will turn a different color.  On toolbar, click “Edit” → “Rotate” (to rotate the resistor to a 
vertical position). Drag the resistor down to align it in parallel with the Voltage Source.

8. Double click the resistor R1 to open the Attributes box. If the value is not already 1k, click the 
“VALUE” line and type “1k” in the value space. Click OK to close the Attributes box.

 

9. Double click the name on V1 and set it to “Vs”. Double click the value (0V) and se it to  “9V”. 

10. Place cursor over the draw wire pencil in the toolbar. “Draw Wire” should 
appear in a pop-up box. Click the pencil to activate wire drawing. Use the 
pencil to connect the top of the voltage source to the top of the resistor, the 
bottom of the voltage source to the ground, and the ground to the bottom of 
the resistor. 

11. Click the V and I buttons on the toolbar  to turn “Enable Voltage Bias Display” and 

Enable Current Bias Display”. They will change to  when they are turned on.

12. If you have not already done this, save your file! 
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Your schematic should now look something like:

13. At the bottom right corner of the schematic, 
double click the first line of the drawing 
information and replace “OrCAD, Inc.” with 
your name. 

Double click “13221 S.W. 68th Parkway, Suite 200” and replace the text with ECE3254. 
Double click “Beaverton, OR 97223” and replace it with 3254 Lab 1-I
Double click “(503) 671-9500   (800) 671-9505”, and replace it with a blank or anything else you 
wish to enter.
Double click “January 1, 2000” and replace it with today’s date.

14. Save your file!

Run the Resistor and DC Source Circuit Simulation

15. Click “Analysis” → “Simulate” or click the Simulate button  (if you hold the cursor over the 

simulate button, the word Simulate will appear below the toolbar) 

16. If there are no errors, the simulation will run and launch a new full page window that looks like 

In the lower left corner, you should see “simulation complete”.

17. Close the simulation window. Go to the Schematic window.
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18. You should see the voltages and currents displayed as below.

19. Click the voltage and current bias displays and drag them slightly clear of the circuit components. 
Show your instructor this simulation and record your results on the Data Sheet.

Part II: Measure the Voltage, Current, Resistance, and  Verify the Pspice Simulation

1. Turn on the lab bench power. Turn on any instruments that do not start up. Turn on the computer 
power and contact your instructor if there are errors reported by Labview.

 2. Obtain a 1000 Ω 1/4W resistor (color code Brown / Black / Red / Gold) resistor from the parts 
drawer.  

Measure the resistance with the Fluke 45 meter. Repeat this measurement with the Agilent 33401A 
meter. 

3. Insert  the 1000Ω resistor into the protoboard and connect as shown in Fig 1-1. For VS, set the 
Agilent W3631A power supply to 9V and connect the power supply to the resistor. 

      ( Fig 1-1 )
Connect the Fluke 45 multimeter in parallel with the resistor to measure the voltage across resistor.
 Repeat the measurement with the Agilent 33401A

4. Reconnect Fluke 45 multimeter in series with the resistor and measure the current through the 
resistor (You will have to lift one leg of the resistor and insert the current meter in series, and move 
the probe connection to the current shunt position on the meter panel as shown below). Repeat the 
measurement with the Agilent 33401A 
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Part III: Pspice Simulation of a Series Resistor Voltage Divider

Enter the circuit of Fig 1-2 into the Pspice Schematic, with Vs = 9VDC, R1 = 1kΩ, and R2 = 560Ω.

 
    Figure 1-2

The easy way: modify the 1-1 schematic.

1. If it is not still open, start pspice and open your 1-1 schematic. 
Save it as Lab1-III (File → Save As → Lab1-III).

2. Right click the top wire near the voltage source – it will change color. Hit the delete key to remove 
the wire.

3. Insert a resistor as we did for part A or by using the “remembered part” drop down on the tool bar 

 (if the resistor is still there) in the space where the deleted wire was. 
Double click the resistor and set “REFDES” = “R2” and “VALUE” = “560”.

4. Reconnect the wires to the resistor to complete the circuit.

5. At the bottom right corner of the schematic double click Lab 1-I and change it to Lab 1-III (and 
also change the date if needed).

6. Save your file!

Run the circuit simulation

7. Make sure that the Bias Display buttons are active.  

8. Click the simulation button to run the simulation as in part A. If there are no errors and the 
simulation completes, close the simulation window and go to the Schematic window. You should 
see the voltages and currents displayed. If you have errors, check your wiring, resistor attributes, 
and VDC attributes.

9. Click the voltage and current bias displays and drag them slightly clear of the circuit components. 
Show your instructor this simulation and record your results on the Data Sheet. Note: VR2 will be 
the difference between the voltages measured at each end of R2 (Vs - VR1)
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Run a circuit transient simulation

10. Click the Bias Display buttons to turn them off. 

11. Click the Voltage Probe (labeled V) on the toolbar and place a voltage probe somewhere 

between R1 and R2 to measure VR1. 

Click Markers → Mark Voltage Differential 
place the first (+) marker between R2 and Vs to measure VR2

place the second (-) marker between R2 and R1 to measure VR2

12. Click the Current probe (labeled I) and place a current probe at the top of R1  (NOTE: you will 
have to place the current probe at the connection point at the end of the resistor, it can be tricky to 
get the probe in the correct place). Hit the Esc key when you are done. 

Your schematic should now look something like this: 

13. Click Analysis → Setup → check the transient box → close

14. Click Analysis → Simulate or click the Simulate button  (if you hold the cursor over the 

simulate button, the word Simulate  will appear below the toolbar )

15. If there are no errors, the simulation will run and the result will show a line at about 5.8V, a line at 
about 3.7V,  and another line near 0V. (If you have errors, make sure that your wires are all 
connected correctly, the resistor value has been set, and the power supply settings are correct.)
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16. Click the “Toggle Cursor” button on the toolbar   The probe 
cursor value box should appear somewhere on the simulation near 
the lower right side. Move the mouse to 0.2s and click the left 
mouse button. A1 should show 200.000n and 5.762, 3.2308 or 
5.769m, depending on which probe trace is active.[text moved]

17. Click the small square, diamond, or triangle  to 
make a trace active. Note, your labels may be 
different.

18. Click the “Mark Label” button on the toolbar . The values 200000n and some other number 

(for nS and V) should appear. 

19. Click each of the other two traces (square, diamond, or triangle) and click the “Mark Label” for 
each trace selected.

20. Click the “Toggle Cursor” button on the tool bar to turn off the cursor – the Probe Cursor box in 
instruction #7 should disappear.

21. Double click the top value label to bring up the label editor.  Insert “ VR1 =  ” at the beginning of 
the second number, and “V” at the end of the text string (should say: 200000n, VR1 = 5.7692V). 
Double click the middle value label and insert “ VR2 =  ” at the beginning of text label string, and 
“V” at the end of the text string (should say: 200000n,  VR2 = 3.2308V).
Double click the bottom value label and insert “ IR = ” at the beginning of the current value, and 
“A” at the end of the text string (should say: 200000n, IR = 5.6792mA).

22. Click the “Text Label” button on the tool bar and type ECE3254 Lab 1-III xxxx, where xxxx is 

your name. Click OK. Drag the text to somewhere near the center of the simulation and right click 
the mouse button to anchor the text.

23. Click the Text Label button on the tool bar and type the date. Anchor the date somewhere below 
the text that says ECE3254 Lab 1-III.

24. Show your instructor this simulation and record your results on the Data Sheet. It should look 
something like this:
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Part IV:   Measure the Series Resistor Voltage Divider

1. Obtain a 560Ω resistor (green, blue, brown, gold) from the parts drawer and measure its resistance 
with the two DMMs.

2. Using the protoboard, build the voltage divider shown in Fig 2-2.  
Keep VS at 9V, let R1 = 1000Ω (1kΩ) and let R2. = 560Ω.
          
Calculate the total resistance seen by Vs (and show equation used).

         Fig 2-2
        

Use either DMM to measure the voltages across R1 and R2 and the current through the resistors. 

3. Before you leave: Shut down Windows, return cables to racks, return parts to correct drawer bins, 
return adapters to container, turn off bench power, clear bench, and place seat under bench. 
(Counts as 5 points of the Lab grade) 
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ECE 3254 Lab 1 Data Sheet    Date______________ Bench_________
(100 points total)
Names:  ________________________  ______________________   ______________________

Part I: Pspice Simulation of a Resistor and a DC Voltage Source

19. Prelab VR1 expected = ____________V   

Prelab IR1 expected = ______________mA 

 Simulated Pspice VR1 = ____________V  (3)  

Simulated Pspice IR1 = ______________mA (3)

TA Verified Pspice simulation complete (names):  (3)

______________________ ______________________ _____________________

Compare the Pspice simulation with the prelab calculation. (5)

Part II: Measure the Voltage, Current, Resistance, and  Verify the Pspice Simulation

2. With the Fluke 45 meter, the 1000Ω resistor measured resistance = _____________Ω  (2)

With the Agilent 33401A meter, 1000Ω resistor measured resistance = _____________ Ω  (2)

3. Prelab VR1 expected = ____________V   Pspice VR1 expected = ____________V (3)

Fluke 45 meas. VR1  =____________V (2)   Agilent 33401A meas. VR1  =____________V  (2)

4. Prelab IR expected = ______________mA   Pspice IR expected = ______________mA (3)

Fluke 45 measured IR1  =__________mA (3) Agilent 33401A measured IR1  =__________mA (3) 

Use the measured voltage and current to calculate R (show formula and calculation) (4) 

Compare the measured resistances from the ohmmeters, the calculated resistance from the voltage 
and current measurements, and the resistor's marked value.(5)

Compare the resistor current and voltage measurements to the expected results from the prelab 
calculations and the pspice simulation. (5)
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Part III: Pspice Simulation of a Series Resistor Voltage Divider

9. Prelab VR1 expected = ____________V     Prelab VR2 expected = ____________V

Prelab IR expected = ______________mA 

Simulated Pspice VR1 = ____________V   (3)  Simulated Pspice VR2 = ____________V  (3)

Simulated Pspice IR = ______________mA (3)     [Note: VR2 =  V at R2 – V at R1]    

TA Verified Pspice simulation complete (names): (5)

______________________ ______________________ _____________________

24. Simulated Pspice VR1 = ____________V  (3)   Simulated Pspice VR2 = ____________V  (3)

Simulated Pspice IR = ______________mA (3) [VR2 is directly measured by the differential probe]

TA Verified Pspice simulation complete (names): (5)

______________________ ______________________ _____________________

Compare the Pspice simulations with the prelab calculations.(5)

Part IV:   Measure the Series Resistor Voltage Divider

1. With the Fluke 45 meter, the 560Ω resistor measured resistance = _____________Ω  (2)

With the Agilent 33401A meter, 560Ω resistor measured resistance = _____________ Ω  (2)

2. Prelab VR1 expected = ____________V     Prelab VR2 expected = ____________V

Prelab IR expected = ______________mA

Expected Rtotal = ___________Ω  (2) Measured R total (R1+R2) = ___________Ω  (2)

Measured VR1  =____________V  (2)  Measured VR2  =____________V  (2)

Measured IR1  =______________mA  (3) Meter Used: ________________ (1)

Compare the resistor current and voltage measurements to the expected results from the prelab 
calculations, and the pspice simulation from Part III. What may account for the differences?(5)

3. Shut down Windows, return cables to racks, return parts to correct drawer bins, return adapters to
container, turn off bench power, clear bench, and place seat under bench. (5)
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